Willkommen Gast. Bitte einloggen oder registrieren.
Mai 27, 2016, 22:00:38
Übersicht Ungelesene Beiträge auflisten Hilfe Suche Spiele Mitgliederkarte Kalender Login Registrieren

Schnellsuche
+  MODDING-FAQ FORUM
|-+  Alles rund ums Modden
| |-+  Elektronik, Elektrik (Moderator: TzA)
| | |-+  [Arduino] Problem mit Adafruit TCS34725 Farbsensor
  « vorheriges nächstes »
0 Mitglieder und 1 Gast betrachten dieses Thema.
Seiten: 1 [2] nach unten Drucken
Autor Thema: [Arduino] Problem mit Adafruit TCS34725 Farbsensor  (Gelesen 8465 mal)
Davemoon
Stichsägenquäler

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 66



Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #15 am: November 5, 2015, 05:06:51 »

so ohne weiteres geht das nich .. aber möglich ist's.

Ich hab mir bei wichtigen Dingen nen Befehl hinzugefügt. Du kannst dir also nach interessanten Schritten nen  Serial.println("Wichtiger Schritt"); Befehl einfügen. Damit siehst du, wo das Programm grade is, bzw. welcher Schritt im Moment bearbeitet wird. Ob der dann auch richtig bearbeitet wird, is erstmal ne andere Frage
Gespeichert

Wie lange eine Minute ist, hängt davon ab auf welcher Seite der Toilettentür man sich befindet
HighEnd
LED-Tauscher

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 44


Es ist selten zu früh und niemals zu spät!


Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #16 am: November 5, 2015, 16:45:27 »

Das blöde dabei ist: An der Stelle, wo's nicht weiter geht, ist bereits ein Print-Befehl: "Color View Test!"

Ich denke mal, einen weiteren Print-Befehl direkt drunter zu schreiben ist nicht  wirklich hilfreich... scheinbar ist direkt vor oder bei der ersten if-Abfrage Feierabend.

Edit: Ist bei Serial.println das l ein kleines L oder ein großes i? Eventuell haben sich die Programmierer da ja verschrieben...?
« Letzte Änderung: November 5, 2015, 16:57:04 von HighEnd » Gespeichert

Never touch my running system!

Hardware:|| bequiet! PP L8 500W | Intel Core i5-3330 @3.70 GHz (@selfmade H2O) | 12 GB DDR3-1333 RAM | Asus P8Z77M Pro | SanDisk 128GB SSD | Transcend 64GB SSD | WD Scorpio Blue 320GB | Gigabyte GTX 780 OC WF3 Rev.2 3GB @ H2O|| WaKü: || AC DC-LT + Aufsatz | AC Bay-AGB | Black Ice GT Stealth 240 @ 2 x NB BSP PL2R| 2x AC NexXxoS ST 30 FC 120 @ NB MF M12-1 | selfmade CPU-Copper-Block | EKWB FC780 GTX WF3 ||
Davemoon
Stichsägenquäler

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 66



Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #17 am: November 5, 2015, 17:45:08 »

dann scheint der if (tcs.begin()) schon Probleme zu machen.. vielleicht meldet sich der Sensor nich zurück ..  aber dann müsste ja die Fehlermeldung kommen..

Leuchtet denn die LED beim Einschalten der Stromversorgung (oder beim Anstecken vom USB Kabel) ??
Gespeichert

Wie lange eine Minute ist, hängt davon ab auf welcher Seite der Toilettentür man sich befindet
HighEnd
LED-Tauscher

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 44


Es ist selten zu früh und niemals zu spät!


Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #18 am: November 5, 2015, 18:33:52 »

Die LED am Sensor leuchtet sofort, wenn die Arduino-Platine Strom bekommt. PWR-LED beim Arduino ebenso. RX und TX leuchten nicht.
Gespeichert

Never touch my running system!

Hardware:|| bequiet! PP L8 500W | Intel Core i5-3330 @3.70 GHz (@selfmade H2O) | 12 GB DDR3-1333 RAM | Asus P8Z77M Pro | SanDisk 128GB SSD | Transcend 64GB SSD | WD Scorpio Blue 320GB | Gigabyte GTX 780 OC WF3 Rev.2 3GB @ H2O|| WaKü: || AC DC-LT + Aufsatz | AC Bay-AGB | Black Ice GT Stealth 240 @ 2 x NB BSP PL2R| 2x AC NexXxoS ST 30 FC 120 @ NB MF M12-1 | selfmade CPU-Copper-Block | EKWB FC780 GTX WF3 ||
Davemoon
Stichsägenquäler

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 66



Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #19 am: November 7, 2015, 19:11:03 »

hm .. verkabelung ok, stromversorung ok, programm ok ... was bleibt also? Sensor defekt?
Gespeichert

Wie lange eine Minute ist, hängt davon ab auf welcher Seite der Toilettentür man sich befindet
OlafSt
Global Moderator

*

Karma: +12/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 2134


Master of STLCD and LISA III


Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #20 am: November 8, 2015, 09:30:36 »

Schon mal was von Sherlock Holmes gehört ?  Grin

Wenn alles andere ausgeschlossen ist, dann muß das, was übrig bleibt - auch wenn es noch so unwahrscheinlich ist - die Wahrheit sein.

Der Sensor ist gehimmelt, das habe ich schon nach dem 2. Post befürchtet. Aber da ich von Adruinos nicht viel verstehe, hab ich mich rausgehalten...
Gespeichert


Erstens: Lies was da steht. Zweitens: Denk drüber nach. Drittens: Dann erst fragen
Davemoon
Stichsägenquäler

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 66



Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #21 am: November 8, 2015, 17:35:52 »

die Sache mit dem gehimmelten Sensor dacht ich mir auch von anfang an, aber bevor man Geld für was neues ausgibt, sucht man erstmal alle kostenlosen Fehlerquellen ab (zumindest mach ich das immer ) Wink
Gespeichert

Wie lange eine Minute ist, hängt davon ab auf welcher Seite der Toilettentür man sich befindet
HighEnd
LED-Tauscher

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 44


Es ist selten zu früh und niemals zu spät!


Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #22 am: November 28, 2015, 08:21:55 »

Moin,

hab jetzt einen Ersatz-Sensor vom Händler bekommen, mit dem es ebenfalls nicht funktioniert. Dass 2 Sensoren kaputt sind, halte ich für unwahrscheinlich, da wär dann bei einer kompletten Charge was schief gelaufen.

Aus Interesse hab ich das Ganze nochmals ohne Sensor getestet. Hier sollte laut Programm dann im seriellen Monitor angezeigt werden, dass der Sensor nicht gefunden wurde. Pustekuchen, außer "Color View Test!" steht gar nichts dran. Es scheint also entweder am Board oder an der Library bzw. den Programmbeispielen zu liegen. Aufgrund dessen, dass ich bis jetzt schon problemlos einige andere Dinge mit dem Board programmiert habe, liegt die Vermutung nahe (@OlafSt: Auschlussverfahren, Sherlok usw... jap, ich kenn das tatsächlich Wink ), dass irgendwas im Programm übersehen wurde.

Weitere und mit meinem Wissensstand letzte Möglichkeit wäre, dass der I²C-Bus vom Board nen Hau hat (mein Wissensstand ist was Arduino angeht noch nicht sehr fortgeschritten, korrigiert mich daher bitte, wenn ich falsch liege und es noch mehr Möglichkeiten gibt! Wink). Da mein Bruder mittlerweile die gleiche Platine hat, können wir das mal testen. Ich hoff, dass es nur am Script liegt.
« Letzte Änderung: November 28, 2015, 08:24:05 von HighEnd » Gespeichert

Never touch my running system!

Hardware:|| bequiet! PP L8 500W | Intel Core i5-3330 @3.70 GHz (@selfmade H2O) | 12 GB DDR3-1333 RAM | Asus P8Z77M Pro | SanDisk 128GB SSD | Transcend 64GB SSD | WD Scorpio Blue 320GB | Gigabyte GTX 780 OC WF3 Rev.2 3GB @ H2O|| WaKü: || AC DC-LT + Aufsatz | AC Bay-AGB | Black Ice GT Stealth 240 @ 2 x NB BSP PL2R| 2x AC NexXxoS ST 30 FC 120 @ NB MF M12-1 | selfmade CPU-Copper-Block | EKWB FC780 GTX WF3 ||
HighEnd
LED-Tauscher

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 44


Es ist selten zu früh und niemals zu spät!


Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #23 am: Dezember 12, 2015, 21:35:58 »

Problem gelöst: Die Platine hat nen Jumper um die 20 Onboard-LEDs zu (de-/) aktivieren. Durch die LEDs am I²C wurde zu viel Spannung vom Bus abgegriffen und dadurch hat der komplette Bus nicht richtig arbeiten können. Einfach die Brücke abziehen und schon hat das Ganze funktioniert. Dass man wegen einer Jumperbrücke insgesamt 4 Tage verschwenden kann...  Grin

War auf jeden Fall cool, den SCL auf dem Oszi zu sehen, mal was anderes als eine normale Sinuskurve  Wink
Gespeichert

Never touch my running system!

Hardware:|| bequiet! PP L8 500W | Intel Core i5-3330 @3.70 GHz (@selfmade H2O) | 12 GB DDR3-1333 RAM | Asus P8Z77M Pro | SanDisk 128GB SSD | Transcend 64GB SSD | WD Scorpio Blue 320GB | Gigabyte GTX 780 OC WF3 Rev.2 3GB @ H2O|| WaKü: || AC DC-LT + Aufsatz | AC Bay-AGB | Black Ice GT Stealth 240 @ 2 x NB BSP PL2R| 2x AC NexXxoS ST 30 FC 120 @ NB MF M12-1 | selfmade CPU-Copper-Block | EKWB FC780 GTX WF3 ||
Davemoon
Stichsägenquäler

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 66



Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #24 am: Dezember 13, 2015, 22:37:41 »

nen Jumper Huh   wo is der denn?
Gespeichert

Wie lange eine Minute ist, hängt davon ab auf welcher Seite der Toilettentür man sich befindet
HighEnd
LED-Tauscher

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 44


Es ist selten zu früh und niemals zu spät!


Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #25 am: Dezember 14, 2015, 04:12:28 »

Man darf nicht vergessen, dass es sich bei der Platine um eine spezielle Anpassung einer Diecimila handelt, die um Lichteffekte erzeugen zu können mit 20 SMD-LEDs ausgestattet ist. Der Jumper befindet sich neben dem USB-Port.

Bildchen: http://media-franzis.e-load.de...ino-platine.jpg
Gespeichert

Never touch my running system!

Hardware:|| bequiet! PP L8 500W | Intel Core i5-3330 @3.70 GHz (@selfmade H2O) | 12 GB DDR3-1333 RAM | Asus P8Z77M Pro | SanDisk 128GB SSD | Transcend 64GB SSD | WD Scorpio Blue 320GB | Gigabyte GTX 780 OC WF3 Rev.2 3GB @ H2O|| WaKü: || AC DC-LT + Aufsatz | AC Bay-AGB | Black Ice GT Stealth 240 @ 2 x NB BSP PL2R| 2x AC NexXxoS ST 30 FC 120 @ NB MF M12-1 | selfmade CPU-Copper-Block | EKWB FC780 GTX WF3 ||
Davemoon
Stichsägenquäler

*

Karma: +0/-0
Offline Offline
Geschlecht: Männlich
Beiträge: 66



Profil anzeigen
Re: [Arduino] Problem mit Adafruit TCS34725 Farbsensor
« Antwort #26 am: Dezember 16, 2015, 06:59:51 »

oh mann Cheesy   da wär ich ja nie drauf gekommen  bestens
Gespeichert

Wie lange eine Minute ist, hängt davon ab auf welcher Seite der Toilettentür man sich befindet
Seiten: 1 [2] nach oben Drucken 
« vorheriges nächstes »
Gehe zu:  

Einloggen mit Benutzername, Passwort und Sitzungslänge      

Powered by MySQL Powered by PHP
eXTReMe Tracker
Seite erstellt in 0.022 Sekunden mit 20 Zugriffen.
© 2001-2009 MODDING-FAQ FORUM | SMF
Alle Rechte vorbehalten.
Prüfe XHTML 1.0! Prüfe CSS!